PowerPoint Pipe search in OLE failing

Discuss WordPipe, ExcelPipe and PowerPointPipe. Get help with installation and running, notify us of bugs, request new features and enhancements.

Moderators: DataMystic Support, Moderators

wgandolph
Posts: 5
Joined: Thu May 14, 2009 9:02 am

PowerPoint Pipe search in OLE failing

Postby wgandolph » Thu May 14, 2009 9:10 am

I have a client with over 4000 Powerpoint documents. We did a server migration and I am searching in OLE DDE links to change FS to SBS. It went through and change a lot, but when spot checked we have found numerous documents where some links are fixed and others are not. I am using one specifically as a test and each time I try - normal search, easypattern, match case or not, it never finds the links it missed the first time. I have tried on XP and Vista. I have tried with Office 2003 and Office 2007. No difference.

I am using version 3.1 Single User Edition. The files are on a network share, but I copied my test file locally and still no change. They have a deadline for getting the reports out, so I am under a lot of pressure here. What could I be missing?

User avatar
DataMystic Support
Site Admin
Posts: 2154
Joined: Mon Jun 30, 2003 12:32 pm
Location: Melbourne, Australia
Contact:

Re: PowerPoint Pipe search in OLE failing

Postby DataMystic Support » Thu May 14, 2009 10:57 am

What is the difference between the links fixed vs not fixed? Are the linked documents missing for example?
Regards,

Simon Carter, http://DataMystic.com/forums/index.php
http://PredictBGL.com - Insulin dose calculator for Type 1 diabetes
http://DownloadPipe.com - 250,000 free software downloads
http://DetachPipe.com - send huge email attachments

wgandolph
Posts: 5
Joined: Thu May 14, 2009 9:02 am

Re: PowerPoint Pipe search in OLE failing

Postby wgandolph » Thu May 14, 2009 2:38 pm

I haven't been able to find a difference. With the old path, the links are missing, but once the edit is made, the link would be present. It appears that some of the links were updated even though the old path was broke, so I was not thinking that it is a problem with the old path being missing. I can do a test though since the old server is still in place. I will re enable the share and try again. I will post if it makes a difference.

wgandolph
Posts: 5
Joined: Thu May 14, 2009 9:02 am

Re: PowerPoint Pipe search in OLE failing

Postby wgandolph » Fri May 15, 2009 1:32 am

I re established the shares on the old server and tried again. No change in the file. Even though I can see 20 links with FS in the path, the program says there is none. I also tried using a Macro VBA that I found that scans a directory and replaces one value with another in the OLE fields and it didn't work either.

If I view the document in notepad, I can see the FS fields as well. I just don't understand why the various apps can't recognize them.

User avatar
DataMystic Support
Site Admin
Posts: 2154
Joined: Mon Jun 30, 2003 12:32 pm
Location: Melbourne, Australia
Contact:

Re: PowerPoint Pipe search in OLE failing

Postby DataMystic Support » Fri May 15, 2009 9:02 am

Please email us a sample
Regards,

Simon Carter, http://DataMystic.com/forums/index.php
http://PredictBGL.com - Insulin dose calculator for Type 1 diabetes
http://DownloadPipe.com - 250,000 free software downloads
http://DetachPipe.com - send huge email attachments

wgandolph
Posts: 5
Joined: Thu May 14, 2009 9:02 am

Re: PowerPoint Pipe search in OLE failing

Postby wgandolph » Fri May 15, 2009 3:05 pm

I used the web site page to send it in with .ppp file and .ppt. I have been double checking to make sure the paths will point to existing files and on systems with the correct programs. The system I am trying to do this from has Excel 2003 and PEP for windows. If needed, I can open a remote session on the machine I am trying to do this from. This is critical for my client as they have to get reports out next week.

User avatar
DataMystic Support
Site Admin
Posts: 2154
Joined: Mon Jun 30, 2003 12:32 pm
Location: Melbourne, Australia
Contact:

Re: PowerPoint Pipe search in OLE failing

Postby DataMystic Support » Fri May 15, 2009 4:19 pm

We have a solution in the works. The old version (3.1.1) did not scan for grouped shapes, and you had a hirarchy of about 3 layers which it did not scan.

The 3.1.2 release fixes the problem.
Regards,

Simon Carter, http://DataMystic.com/forums/index.php
http://PredictBGL.com - Insulin dose calculator for Type 1 diabetes
http://DownloadPipe.com - 250,000 free software downloads
http://DetachPipe.com - send huge email attachments

wgandolph
Posts: 5
Joined: Thu May 14, 2009 9:02 am

Re: PowerPoint Pipe search in OLE failing

Postby wgandolph » Sat May 16, 2009 2:53 am

Tested this morning with new version. Thank you - it worked. I can go forward fixing all my clients documents and that will knock the stress levels down a notch here!


Return to “WordPipe, ExcelPipe and PowerPointPipe Support”

Who is online

Users browsing this forum: No registered users and 1 guest