detachpipe 5.8 Lite and encodings

Discuss DetachPipe.com huge attachment service and DetachPipe attachment management Add On for Microsoft Outlook. Get help with installation and running, notify us of bugs, request new features and enhancements.

Moderators: DataMystic Support, Moderators

doka_ua
Posts: 5
Joined: Tue Jun 30, 2009 5:27 pm

detachpipe 5.8 Lite and encodings

Postby doka_ua » Tue Jun 30, 2009 5:36 pm

Colleagues,

there is problem in DetachPipe Lite, which makes it impossible to use, actually. After I detach attachments (as well as delete them from message) DetachPipe modifies message in way when Outlook then isn't able to show non-English encodings (actually, I'm using Cyrillic Windows-1251). Please, check message before and after DetachPipe done work on it:

http://vugluskr.mml.org.ua/~doka/dpipe/ ... detach.msg
http://vugluskr.mml.org.ua/~doka/dpipe/ ... detach.msg

I'm Vladimir Litovka, registered user and will provide receipt number upon request (not sure forum is right place to publish it)

Any questions are highly welcome, I'll provide any additional diagnostics for this issue.

Thank you.

User avatar
DataMystic Support
Site Admin
Posts: 2136
Joined: Mon Jun 30, 2003 12:32 pm
Location: Melbourne, Australia
Contact:

Re: detachpipe 5.8 Lite and encodings

Postby DataMystic Support » Wed Jul 01, 2009 9:14 am

Thanks Vlad,

Looking into it now.
Regards,

Simon Carter, http://DataMystic.com/forums/index.php
http://PredictBGL.com - Insulin dose calculator for Type 1 diabetes
http://DownloadPipe.com - 250,000 free software downloads
http://DetachPipe.com - send huge email attachments

User avatar
DataMystic Support
Site Admin
Posts: 2136
Joined: Mon Jun 30, 2003 12:32 pm
Location: Melbourne, Australia
Contact:

Re: detachpipe 5.8 Lite and encodings

Postby DataMystic Support » Thu Jul 02, 2009 10:50 pm

Hi Vlad,

Using a debugger I can see that the codepage of your email is 1251 and it is a plain text message.

When we request a HTML variant of the page, it inserts text saying that the page is in koi8-r format, and it changes the cyrillic text to something else.

It's not actually DetachPipe doing this, but I'm not sure what to advise here. DetachPipe needs to insert a link. But Outlook is not doing the right thing.
Regards,

Simon Carter, http://DataMystic.com/forums/index.php
http://PredictBGL.com - Insulin dose calculator for Type 1 diabetes
http://DownloadPipe.com - 250,000 free software downloads
http://DetachPipe.com - send huge email attachments

doka_ua
Posts: 5
Joined: Tue Jun 30, 2009 5:27 pm

Re: detachpipe 5.8 Lite and encodings

Postby doka_ua » Thu Jul 30, 2009 7:24 pm

Simon, hi

DataMystic Support wrote:Hi Vlad,

Using a debugger I can see that the codepage of your email is 1251 and it is a plain text message.

When we request a HTML variant of the page, it inserts text saying that the page is in koi8-r format, and it changes the cyrillic text to something else.

It's not actually DetachPipe doing this, but I'm not sure what to advise here. DetachPipe needs to insert a link. But Outlook is not doing the right thing.


the problem is that issue appeared after upgrade (unfortunately, I don't remember, which one upgrade introduced the problem) without any changes in Outlook configuration. Anyway, I've tried to change encoding from KOI8-R (I was using this one) to 1251 and tried again to detach attachment. The same problem - my cyrillic became unreadable.

I still think, that this problem is in DetachPipe, since I didn't any changes to encodings configuration during DetachPipe's upgrades. Could you, please, post for me older version of DetachPipe (preferable - the one I've bought, again - I don't remember which one it was) and I check whether this problem will exist.

Thank you

User avatar
DataMystic Support
Site Admin
Posts: 2136
Joined: Mon Jun 30, 2003 12:32 pm
Location: Melbourne, Australia
Contact:

Re: detachpipe 5.8 Lite and encodings

Postby DataMystic Support » Thu Jul 30, 2009 8:58 pm

We've added a new download button in the secure area to download 5.7.9e - this is just below the current version download button.
Regards,

Simon Carter, http://DataMystic.com/forums/index.php
http://PredictBGL.com - Insulin dose calculator for Type 1 diabetes
http://DownloadPipe.com - 250,000 free software downloads
http://DetachPipe.com - send huge email attachments

doka_ua
Posts: 5
Joined: Tue Jun 30, 2009 5:27 pm

Re: detachpipe 5.8 Lite and encodings

Postby doka_ua » Thu Jul 30, 2009 11:31 pm

DataMystic Support wrote:We've added a new download button in the secure area to download 5.7.9e - this is just below the current version download button.


Ok, I've downloaded old version, thanks.

The short findings are:

1) the problem is in old version too
2) it doesn't matter, whether message in HTML or plain-text format
3) problem doesn't appear, if Unicode encoding used on sending side. If sending side change encoding to KOI8-r or cp1251 (i.e. non-Unicode), then message will be unreadable after detachpipe

Could you, please, comment this?

All tests done on Outlook 2003 (11.8217.8221) SP3, Windows XP SP2.

User avatar
DataMystic Support
Site Admin
Posts: 2136
Joined: Mon Jun 30, 2003 12:32 pm
Location: Melbourne, Australia
Contact:

Re: detachpipe 5.8 Lite and encodings

Postby DataMystic Support » Fri Jul 31, 2009 10:21 am

We don't change the encoding. I suspect that even if we give you an older version, like 5.6.x, that the problem will still be there, because something in Windows has changed.

If you want to test this using DetachPipe 5.6.7 please login and give it a shot (there is a new button now). I'll be interested to hear the result!
Regards,

Simon Carter, http://DataMystic.com/forums/index.php
http://PredictBGL.com - Insulin dose calculator for Type 1 diabetes
http://DownloadPipe.com - 250,000 free software downloads
http://DetachPipe.com - send huge email attachments

doka_ua
Posts: 5
Joined: Tue Jun 30, 2009 5:27 pm

Re: detachpipe 5.8 Lite and encodings

Postby doka_ua » Mon Aug 03, 2009 5:14 pm

DataMystic Support wrote:We don't change the encoding. I suspect that even if we give you an older version, like 5.6.x, that the problem will still be there, because something in Windows has changed.


Simon, I believe you don't change encoding. But the matter of fact is: if DetachPipe receives from Outlook message with non-English/non-Unicode encoding, result is garbled. I don't know for sure, where is problem, but if this is Outlook's problem, you probably need to have workaround for this.

User avatar
DataMystic Support
Site Admin
Posts: 2136
Joined: Mon Jun 30, 2003 12:32 pm
Location: Melbourne, Australia
Contact:

Re: detachpipe 5.8 Lite and encodings

Postby DataMystic Support » Wed Aug 05, 2009 7:57 pm

We'll try and create a workaround - such as by converting to utf-8 first. Did you check the 5.6.7 version just to see if it worked?
Regards,

Simon Carter, http://DataMystic.com/forums/index.php
http://PredictBGL.com - Insulin dose calculator for Type 1 diabetes
http://DownloadPipe.com - 250,000 free software downloads
http://DetachPipe.com - send huge email attachments

doka_ua
Posts: 5
Joined: Tue Jun 30, 2009 5:27 pm

Re: detachpipe 5.8 Lite and encodings

Postby doka_ua » Wed Aug 05, 2009 9:49 pm

DataMystic Support wrote:We'll try and create a workaround - such as by converting to utf-8 first. Did you check the 5.6.7 version just to see if it worked?


Simon, hi, it seems that 5.6.7 don't have this problem, at least I can't reproduce it.

So, you have what to compare :) Hope you'll release fixed version soon :)


Return to “DetachPipe.com and DetachPipe Add On Support”

Who is online

Users browsing this forum: No registered users and 1 guest