Page 1 of 1

TextPipe 11 has removed some of my Windows Shell Extensions!

Posted: Wed Mar 18, 2020 1:46 am
by DFH
Have you set an arbitrary limit on the number of shell extensions one can have?

Since installing TextPipe v11.x (now 11.4), I found that the Context Menu for TextPipe now has a few of my earlier Windows Shell Extension options missing.

I had almost 50 extensions before, but now the last one is number 45, with number 46 being a blank in the registry.

The registry entries for the others have vanished.
Alas, I never thought to export the registry branch before updating from TextPipe 10.9.

I just tried adding a new extension, and I did use Apply afterwards.
Afterwards, the new entry (number 46) had vanished.
So it looks as though you've set a limit of 45 extensions.

Very frustrating!



Re: TextPipe 11 has removed some of my Windows Shell Extensions!

Posted: Sat Mar 28, 2020 12:35 am
by DFH
It seems that my restored entry 46 does now show in the Windows Explorer Shell menu for TextPipe,
even though the table still only displays 45 rows in the editing UI.

However, selecting this bottom entry from Windows Explorer Context Menu results in the specified filter not being found!

It seems to have a problem with the spaces in the filter file name. See

Looks as though there's an off-by-one error! See

After adding a new row, then using Apply then OK, upon opening the Customize UI again, the new row had vanished!

However, after adding two new rows, the second such row #47 vanished from the table, even though both #46 and #47 had become visible in the Explorer menu. #46 still gave the same error when used.

The filter column for row #46 had also changed from being without double quotes to having the full path filename being enclosed in quotes.

However, if I then edited the cell again to remove the double quotes, after Apply, OK and exiting TextPipe, the filter in #46 could be launched successfully from the Context Menu!

NB. This first required adding row #47 again, to workaround the Off-by-one error.

Please fix these two related issues asap. Thanks.