Search and replace problems in unicode files

Get help with installation and running here.

Moderators: DataMystic Support, Moderators


Search and replace problems in unicode files

Postby Tobias » Wed Feb 23, 2005 4:48 pm

I'm trying to make some changes to a japanese xml file, but I dont get any maches for my search strings (both perl patterns and exact). In trial area, i get perfect maches if I disable "treat input as unicode" so I suspect I have missed something about how unicode is treated in patterns.

Even the simplest search fails, for instance, a pearl or exakt search for just the caracters ref fails, even though I have checked the Enable UTF-8 support box in Matching options. (Of course I want to do a more complex search then this, but when trouble shooting I removed more and more stuff from the pattern until there was only ordinary characters left).[/b].

User avatar
DataMystic Support
Site Admin
Posts: 2139
Joined: Mon Jun 30, 2003 12:32 pm
Location: Melbourne, Australia

Postby DataMystic Support » Thu Feb 24, 2005 8:43 am

Hi Tobias,

When you paste data into the Trial Run area, it gets stored in Windows' native Unicode format, UTF16 (LE). With the 'Treat as Unicode' option disabled, this gets converted to ANSI prior to processing.

What is the format of your file?

Can you please email me your filter and a sample file for comparison?

Simon Carter, - Insulin dose calculator for Type 1 diabetes - 250,000 free software downloads - send huge email attachments

Return to “TextPipe Tips and Tricks, Questions and Support”

Who is online

Users browsing this forum: Baidu [Spider] and 5 guests