UTF-8 support in Replace List filters?

Get help with installation and running here.

Moderators: DataMystic Support, Moderators

DFH
Posts: 636
Joined: Sun Dec 09, 2007 2:49 am
Location: UK

UTF-8 support in Replace List filters?

Postby DFH » Sat Jul 27, 2013 5:58 am

The recent versions 9.5.1 and 9.5.2 state this in the release notes:
When Utf8 Support is checked for replace filters, Unicode characters in the
search for and replace with fields are now correctly converted to UTF-8 prior
to being processed by the PCRE engine.
Fixed UTF-8 mode perl pattern replace strings from being converted to utf-8.

It's evident that this new aspect of UT-8 support appertains only to the Replace filter, but not to the Replace list filter.

I can paste UTF-8 characters into both search and replace fields for a Perl Replace filter, with UTF-8 support already ticked, and they display as pasted.

Yet when I paste the same characters into a Perl Replace List filter, with UTF-8 support already ticked, accented characters are stripped of their accents and/or the Unicode characters are converted to a question mark.

Please explain the design philosophy for this difference.

DFH
Posts: 636
Joined: Sun Dec 09, 2007 2:49 am
Location: UK

Re: UTF-8 support in Replace List filters?

Postby DFH » Thu Apr 07, 2016 3:48 am

Still awaiting a reply.

User avatar
DataMystic Support
Site Admin
Posts: 2138
Joined: Mon Jun 30, 2003 12:32 pm
Location: Melbourne, Australia
Contact:

Re: UTF-8 support in Replace List filters?

Postby DataMystic Support » Sun Aug 07, 2016 11:48 pm

This has been fixed for the next release
Regards,

Simon Carter, http://DataMystic.com/forums/index.php
http://PredictBGL.com - Insulin dose calculator for Type 1 diabetes
http://DownloadPipe.com - 250,000 free software downloads
http://DetachPipe.com - send huge email attachments


Return to “TextPipe Tips and Tricks, Questions and Support”

Who is online

Users browsing this forum: No registered users and 5 guests