Bug in text format of clipboard copy of filters

Get help with installation and running here.

Moderators: DataMystic Support, Moderators

DFH
Posts: 636
Joined: Sun Dec 09, 2007 2:49 am
Location: UK

Bug in text format of clipboard copy of filters

Postby DFH » Fri Mar 15, 2013 7:00 pm

I just observed that in a highly structured and amply commented filter,
some of the internal replace list filters are not placed in the correct nested hierarchy
when the filter is copied to clipboard and then pasted into a text file.

Rather they are flushed to the left margin.
I would count this as a software bug.

This is especially serious when such filters are sub-filters of a restrict filter,
as the text copy has then become "misleading documentation".

It's bad enough that they are not placed correctly even when all their 'ancestors' are comment filters.

David
Last edited by DFH on Fri Mar 15, 2013 7:17 pm, edited 2 times in total.

DFH
Posts: 636
Joined: Sun Dec 09, 2007 2:49 am
Location: UK

Re: Bug in text format of clipboard copy of filters

Postby DFH » Fri Mar 15, 2013 7:03 pm

I have emailed an example directly to Simon Carter.

Search the text file using regexp ^\w

Lines delinquently places begin with

Code: Select all

Replace
Perl pattern

User avatar
DataMystic Support
Site Admin
Posts: 2138
Joined: Mon Jun 30, 2003 12:32 pm
Location: Melbourne, Australia
Contact:

Re: Bug in text format of clipboard copy of filters

Postby DataMystic Support » Tue Mar 26, 2013 4:13 pm

Ok, this is done ready for the next release.
Regards,

Simon Carter, http://DataMystic.com/forums/index.php
http://PredictBGL.com - Insulin dose calculator for Type 1 diabetes
http://DownloadPipe.com - 250,000 free software downloads
http://DetachPipe.com - send huge email attachments

DFH
Posts: 636
Joined: Sun Dec 09, 2007 2:49 am
Location: UK

Re: Bug in text format of clipboard copy of filters

Postby DFH » Tue Mar 26, 2013 10:26 pm

Thanks, Simon.

DFH
Posts: 636
Joined: Sun Dec 09, 2007 2:49 am
Location: UK

Re: Bug in text format of clipboard copy of filters

Postby DFH » Sun Apr 07, 2013 6:08 pm

I confirm that this fix worked OK in TextPipe 9.4

David


Return to “TextPipe Tips and Tricks, Questions and Support”

Who is online

Users browsing this forum: No registered users and 1 guest