TextPipe 8.9 sometimes stops working

Get help with installation and running here.

Moderators: DataMystic Support, Moderators

DFH
Posts: 636
Joined: Sun Dec 09, 2007 2:49 am
Location: UK

TextPipe 8.9 sometimes stops working

Postby DFH » Fri Jul 15, 2011 9:03 pm

TextPipe 8.9 sometimes stops working while I am developing a filter and trying things out.
i.e. It stops responding in Windows 7 x64, and even Task Manager cannot close it.
I have to log off my user account and force it to close during log off.
This problem has occurred three times in the last 30 minutes.

Previous versions of TextPipe Standard would at least end gracefully.

Not a happy bunny!

David

User avatar
DataMystic Support
Site Admin
Posts: 2138
Joined: Mon Jun 30, 2003 12:32 pm
Location: Melbourne, Australia
Contact:

Re: TextPipe 8.9 sometimes stops working

Postby DataMystic Support » Mon Jul 18, 2011 11:49 am

Do you think this was related to a modal dialog appearing but being actually hidden behind TP's main window? This happens with other apps too, and it can be forced to appear usually by Alt+Tabbing away from TP, then Alt+Tabbing back again.
Regards,

Simon Carter, http://DataMystic.com/forums/index.php
http://PredictBGL.com - Insulin dose calculator for Type 1 diabetes
http://DownloadPipe.com - 250,000 free software downloads
http://DetachPipe.com - send huge email attachments

DFH
Posts: 636
Joined: Sun Dec 09, 2007 2:49 am
Location: UK

Re: TextPipe 8.9 sometimes stops working

Postby DFH » Tue Jul 19, 2011 4:06 am

Simon,

I have not seen any such dialog, and I know about {Alt-Tab}.

The circumstances that cause the problem seem almost random, except that they all happened immediately after I clicked on Go.
It's very frustrating if I had not already saved my edits to the filter, as then I have to recall what I was doing.
But it's almost equally frustrating to see the application freeze just after I have saved the filter.

David

User avatar
DataMystic Support
Site Admin
Posts: 2138
Joined: Mon Jun 30, 2003 12:32 pm
Location: Melbourne, Australia
Contact:

Re: TextPipe 8.9 sometimes stops working

Postby DataMystic Support » Tue Jul 19, 2011 9:51 pm

v8.9.2 Releasing now

* Fixed bug with the way that PlaySound was called at the end of the filter job
which caused crashes. A baffling Unicode string issue that seems to have gone away through the use of an intermediate variable (ie is a compiler issue).
Regards,

Simon Carter, http://DataMystic.com/forums/index.php
http://PredictBGL.com - Insulin dose calculator for Type 1 diabetes
http://DownloadPipe.com - 250,000 free software downloads
http://DetachPipe.com - send huge email attachments

DFH
Posts: 636
Joined: Sun Dec 09, 2007 2:49 am
Location: UK

Re: TextPipe 8.9 sometimes stops working

Postby DFH » Thu Jul 21, 2011 1:47 am

Just installed v8.9.2 so I will see if the issue goes away.

David

DFH
Posts: 636
Joined: Sun Dec 09, 2007 2:49 am
Location: UK

Re: TextPipe 8.9 sometimes stops working

Postby DFH » Thu Jul 21, 2011 7:05 am

If playsound is called at the end of a job, how come the crashes I saw usually occurred immediately after clicking the Go button?
i.e. Before any progress through the filter.

User avatar
DataMystic Support
Site Admin
Posts: 2138
Joined: Mon Jun 30, 2003 12:32 pm
Location: Melbourne, Australia
Contact:

Re: TextPipe 8.9 sometimes stops working

Postby DataMystic Support » Thu Jul 21, 2011 8:35 am

The crashes seem to occur on the second run of a filter. The processing thread is not ending properly, and hence the timer which shows elapsed time is not disabled - here I get two separate threads changing the elapsed time count. The crash occurs on the PlaySound function here, but we are looking for other causes, as we have reverted this code back to pre-unicode filename handling with no improvement.

We are looking very hard for the cause and should have it sorted out today.
Regards,

Simon Carter, http://DataMystic.com/forums/index.php
http://PredictBGL.com - Insulin dose calculator for Type 1 diabetes
http://DownloadPipe.com - 250,000 free software downloads
http://DetachPipe.com - send huge email attachments

DFH
Posts: 636
Joined: Sun Dec 09, 2007 2:49 am
Location: UK

Re: TextPipe 8.9 sometimes stops working

Postby DFH » Thu Jul 21, 2011 11:05 pm

Version 8.9.2 just froze on me!

User avatar
DataMystic Support
Site Admin
Posts: 2138
Joined: Mon Jun 30, 2003 12:32 pm
Location: Melbourne, Australia
Contact:

Re: TextPipe 8.9 sometimes stops working

Postby DataMystic Support » Fri Jul 22, 2011 9:11 am

Hi David - I need more info. What were you doing at the time? Were you running a filter for the second time?
Regards,

Simon Carter, http://DataMystic.com/forums/index.php
http://PredictBGL.com - Insulin dose calculator for Type 1 diabetes
http://DownloadPipe.com - 250,000 free software downloads
http://DetachPipe.com - send huge email attachments

DFH
Posts: 636
Joined: Sun Dec 09, 2007 2:49 am
Location: UK

Re: TextPipe 8.9 sometimes stops working

Postby DFH » Fri Jul 22, 2011 6:07 pm

It's hard to be sure, as these things creep up on you unexpectedly.

Though some of these occasions are not the first time I'd run the filter in the same session, I reckon there must have been some that were.

David

DFH
Posts: 636
Joined: Sun Dec 09, 2007 2:49 am
Location: UK

Re: TextPipe 8.9 sometimes stops working

Postby DFH » Wed Jul 27, 2011 4:33 am

Having just installed 8.9.3, I will have to keep a watch for this issue.

David

User avatar
DataMystic Support
Site Admin
Posts: 2138
Joined: Mon Jun 30, 2003 12:32 pm
Location: Melbourne, Australia
Contact:

Re: TextPipe 8.9 sometimes stops working

Postby DataMystic Support » Wed Jul 27, 2011 9:21 am

Please do! But I am confident we have fixed it this time. If not, it will be much easier to track down in future.
Regards,

Simon Carter, http://DataMystic.com/forums/index.php
http://PredictBGL.com - Insulin dose calculator for Type 1 diabetes
http://DownloadPipe.com - 250,000 free software downloads
http://DetachPipe.com - send huge email attachments


Return to “TextPipe Tips and Tricks, Questions and Support”

Who is online

Users browsing this forum: No registered users and 6 guests