Timestamps in logging (bug report)

Get help with installation and running here.

Moderators: DataMystic Support, Moderators

DFH
Posts: 636
Joined: Sun Dec 09, 2007 2:49 am
Location: UK

Timestamps in logging (bug report)

Postby DFH » Wed Jun 22, 2011 6:29 pm

Simon,

I just spotted a bug in how TextPipe records the timestamps in the log file and in Status output.

Having left TextPipe running (dormant) with my computer asleep overnight, I was surprised that when I ran a filter this morning, all the timestamps had yesterday's date.

It would seem that TextPipe records the date and time when the application itself was opened, rather than the instantaneous times that each subfilter is logged.

David

User avatar
DataMystic Support
Site Admin
Posts: 2138
Joined: Mon Jun 30, 2003 12:32 pm
Location: Melbourne, Australia
Contact:

Re: Timestamps in logging (bug report)

Postby DataMystic Support » Tue Jun 28, 2011 9:56 pm

Very strange David. I can assure you than the logging using the current value of clock (now()) for each log line.

My only thought is that you had a Prompt on Replace paused on the screen when your computer was asleep.

But I suspect instead that Windows is protecting TP from a large clock 'hit' and is falsely giving it this time.

You can check by running a filter with a search/replace with prompting - check the value of @DATETIME to see the date that is truly being reported.
Regards,

Simon Carter, http://DataMystic.com/forums/index.php
http://PredictBGL.com - Insulin dose calculator for Type 1 diabetes
http://DownloadPipe.com - 250,000 free software downloads
http://DetachPipe.com - send huge email attachments

DFH
Posts: 636
Joined: Sun Dec 09, 2007 2:49 am
Location: UK

Re: Timestamps in logging (bug report)

Postby DFH » Wed Jun 29, 2011 5:59 pm

Simon,

It didn't just happen while the computer was in Sleep mode!

I wonder if this is a hitherto unnoticed quirk of Windows 7 x64 ?

David

User avatar
DataMystic Support
Site Admin
Posts: 2138
Joined: Mon Jun 30, 2003 12:32 pm
Location: Melbourne, Australia
Contact:

Re: Timestamps in logging (bug report)

Postby DataMystic Support » Fri Jul 01, 2011 9:29 am

Hi David,

I ran a filter (trial run area), left TP running for 24 hours, with the computer put into hibernation twice, and ran the same trial run filter again. I did not see any problem like you describe.

Please let me know if you can reproduce it.
Regards,

Simon Carter, http://DataMystic.com/forums/index.php
http://PredictBGL.com - Insulin dose calculator for Type 1 diabetes
http://DownloadPipe.com - 250,000 free software downloads
http://DetachPipe.com - send huge email attachments

User avatar
DataMystic Support
Site Admin
Posts: 2138
Joined: Mon Jun 30, 2003 12:32 pm
Location: Melbourne, Australia
Contact:

Re: Timestamps in logging (bug report)

Postby DataMystic Support » Tue Jul 05, 2011 11:43 am

BTW - I suspect hibernation/sleep of the computer overnight has a lot to do with it - but TP does NOT cache the date stamp at all- it regenerates it from the system time, each time (note - this was originally posted incorrectly in reply to another thread)
Regards,

Simon Carter, http://DataMystic.com/forums/index.php
http://PredictBGL.com - Insulin dose calculator for Type 1 diabetes
http://DownloadPipe.com - 250,000 free software downloads
http://DetachPipe.com - send huge email attachments


Return to “TextPipe Tips and Tricks, Questions and Support”

Who is online

Users browsing this forum: No registered users and 2 guests